Back to overview
Degraded

Computer Operations Delays

Jun 2, 2026 at 6:10pm UTC
Affected services
App

Resolved
Jun 2, 2026 at 6:42pm UTC

This issue has now been resolved.

Created
Jun 2, 2026 at 6:10pm UTC

We are experiencing an issue from a downstream provider that may be causing some Obvious operations involving computer use to be slower than usual. We are working with the vendor to get this resolved as quickly as possible.