Back to overview
Degraded

Users Unable to Login In Chrome - Other Browsers OK

Apr 2, 2026 at 8:43pm UTC
Affected services
App

Resolved
Apr 2, 2026 at 9:03pm UTC

We are still working on resolving the root cause but clearing your cache or using an incognito window will allow you to log in again.

Created
Apr 2, 2026 at 8:43pm UTC

We are currently seeing an issue where some users cannot log in to Obvious using the Chrome browser. Please use another browser to log in for the time being.