Back to overview
Degraded
Workbooks/Sheets Not Saving Updates
Mar 12, 2026 at 5:30pm UTC
Affected services
Artifacts
Resolved
Mar 12, 2026 at 9:58pm UTC
We have pushed out a fix and are monitoring the results.
Affected services
Updated
Mar 12, 2026 at 8:45pm UTC
We are currently testing a fix and will be pushing out a release with a fix soon. We appreciate your patience.
Affected services
Created
Mar 12, 2026 at 5:30pm UTC
We are currently seeing an issue where some workbooks/sheets are not saving updates. We are working to get this fixed as quickly as possible
Affected services